Services up with intermittent degraded service due to global AWS degraded service

Incident Report for Arcadia

Resolved

AWS has resolved all issues. After thorough monitoring, Arcadia products had some slowdown in select services but no major outages
Posted Oct 20, 2025 - 21:02 EDT

Monitoring

Services are generally still functional but we have identified a few intermittent issues leading to degraded performance in some products. The cause is the global AWS degraded service https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 11:57 EDT
This incident affected: UDS (Portal, Portal API, SourceViewer), Utility Data Platform (Console, Connect, AuthServer, On Demand API, Utility Cloud API), and Arcadia Platform (Plug API, Connect 2, Dashboard, Auth Service).